Информатика 9. Конструирование алгоритмов

Информатика 9 класс.
Тест: Конструирование алгоритмов

Рекомендуется вначале прочитать конспект урока «Информатика 9 класс. Конструирование алгоритмов».  В настоящем тесте всего 8 вопросов. Нет ограничения по времени. В случае явно плохих результатов (меньше 15% правильных ответов) тестирование по теме «Информатика 9. Конструирование алгоритмов» заканчивается досрочно! Неудовлетворительная оценка выставляется, если правильных ответов меньше 50% ! Вернуться на страницу «Информатика 9 класс».

 13%
1. Дана следующая программа.

вниз

нц пока справа стена и слева стена

закрасить; вниз

кц

Выполняя эту программу, исполнитель Робот закрасит все клетки, находящиеся:
2. Вспомогательный алгоритм целесообразно использовать при составлении программы:
3. Исполнитель Робот выполняет программу в лабиринте.
Количество клеток лабиринта, соответствующих требованию, что, выполнив программу, Робот уцелеет и остановится в той же клетке, с которой он начал движение:
4. Рекурсивным является алгоритм:
5. Дана следующая программа.

нц пока справа стена и слева стена

закрасить; вверх

кц

Выполняя эту программу, исполнитель Робот закрасит все клетки, находящиеся:
6. Вспомогательный алгоритм целесообразно использовать при составлении программы:
7. Исполнитель Робот выполняет программу в лабиринте.

Количество клеток лабиринта, соответствующих требованию, что, выполнив программу, Робот уцелеет и остановится в той же клетке, с которой он начал движение:
8. Рекурсивным является алгоритм:

 

Вас могут заинтересовать...

Leave a Comment